码迷,mamicode.com
首页 > 其他好文 > 详细

UVA Lining Up (一条直线上最多的点数)

时间:2015-02-02 15:58:11      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:

Description

技术分享


 Lining Up 

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3


     题意:求在一条直线上的点最多有几个。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

struct node
{
    int x;
    int y;
} q[710];
char str[1001];
int findx(int x1,int y1,int x2,int y2,int x3,int y3)
{
    if((x1-x2)*(y2-y3)-(y1-y2)*(x2-x3) == 0)
    {
        return 1;
    }
    return 0;
}

int main()
{
    int T;
    scanf("%d\n",&T);
    while(T--)
    {
        int n = 0;
        while(gets(str))
        {
            if(!str[0])
            {
                break;
            }
            sscanf(str,"%d%d",&q[n].x,&q[n].y);
            n++;

        }
        if(n<=3)
        {
            printf("%d\n",n-1);
            continue;
        }
        int maxx = 0;
        for(int i=0; i<n; i++)
        {
            for(int j=i+1; j<n; j++)
            {
                int cnt = 2;
                for(int k=j+1; k<n; k++)
                {
                    if(findx(q[i].x,q[i].y,q[j].x,q[j].y,q[k].x,q[k].y) == 1)
                    {
                        cnt++;
                    }
                }
                if(maxx < cnt)
                {
                    maxx = cnt;
                }
            }
        }
        printf("%d\n",maxx);
        if(T)
        {
            printf("\n");
        }
    }
    return 0;
}


UVA Lining Up (一条直线上最多的点数)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/43408487

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!