码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu 2.2.4)Wolf and Rabbit(一个圆有n个数,每次数m个数,看能否遍历这个圆)

时间:2015-02-02 18:08:36      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2021 Accepted Submission(s): 1146
 
Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.

技术分享


A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output

            For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 
Sample Input
2
1 2
2 2
 
Sample Output
NO
YES
 
Author
weigang Lee
 
Source
杭州电子科技大学第三届程序设计大赛
 
Recommend
Ignatius.L



题目分析:

             这道题其实和http://blog.csdn.net/hjd_love_zzt/article/details/43194213 hdu step 1.2.2这道题是一模一样的,

只是把情景换一下而已。这道题实际抽象以下就是“一个圆有n个数,每次数m个数,看能否遍历这个圆” 。这实际上

判断一下n,m是否负责就行。判断互质的过程用到了求最大公约数的方法。



代码如下:

/*
 * c.cpp
 *
 *  Created on: 2015年2月2日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>


using namespace std;


int gcd(int a,int b){
	int temp;
	while(b != 0){
		temp = b;
		b = a%b;
		a = temp;
	}

	return a;
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int a,b;
		scanf("%d%d",&a,&b);
		if(gcd(a,b) == 1){
			printf("NO\n");
		}else{
			printf("YES\n");
		}
	}

	return 0;
}



       



(hdu 2.2.4)Wolf and Rabbit(一个圆有n个数,每次数m个数,看能否遍历这个圆)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/43410617

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!