码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2739. Sum of Consecutive Prime Numbers

时间:2015-02-02 22:45:31      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:

Sum of Consecutive Prime Numbers
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 20050Accepted: 10989

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source

 
简单打表水题,往下写之前先看看 10000 内的素数有多少个,然后就可以开数组给OJ生成了,或者自己复制粘贴好数组交上去。
得到数组就可以对数组进行游标法遍历了,不难。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <stdio.h>
#include <math.h>
int pr[1229];
int ispr(int n)
{
    int p=sqrt(n);
    for(int i=2;i<=p;i++)
        if(n%i==0) return 0;
    return 1;
}
int main()
{
    int n,cnt=0;
    int i,j,c;
    long sum;

    for(i=2;i<=10000;i++)
        if(ispr(i))
            pr[cnt++]=i;

    while(~scanf("%d",&n)&&n)
    {
        c=0;
        for(i=0;i<cnt&&pr[i]<=n;i++)
        {
            sum=0;
            for(j=i;j<cnt;j++)
            {
                sum+=pr[j];
                if(sum>=n) break;
            }
            if(sum==n) c++;
        }
        printf("%d\n",c);
    }
    return 0;
}
 




POJ 2739. Sum of Consecutive Prime Numbers

标签:

原文地址:http://www.cnblogs.com/BlackStorm/p/4268686.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!