码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533-Longest Ordered Subsequence(dp_最长上升子序列)

时间:2015-02-02 23:14:01      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 35502   Accepted: 15572

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:求最长上升子序列。

思路:令A[i]表示输入第i个元素,D[i]表示从A[1]到A[i]中以A[i]结尾的最长子序列长度。对于任意的0 <  j <= i-1,如果A(j) < A(i),则A(i)可以接在A(j)后面形成一个以A(i)结尾的新的最长上升子序列。对于所有的 0 <  j <= i-1,我们需要找出其中的最大值。
DP状态转移方程:
D[i] = max{1, D[j] + 1} (j = 1, 2, 3, ..., i-1 且 A[j] < A[i])
解释一下这个方程,i, j在范围内:
如果 A[j] < A[i] ,则D[i] = D[j] + 1
如果 A[j] >= A[i] ,则D[i] = 1


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;

const int inf=0x3f3f3f3f;
int dp[1010];
int a[1010];

int main()
{
    int n,i,j;
    int maxx;
    int cnt=1;
    while(~scanf("%d",&n)){
        maxx=-inf;
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(i=1;i<=n;i++){
            dp[i]=1;
            for(j=1;j<i;j++){
                if(a[j]<a[i]&&dp[i]<dp[j]+1)
                    dp[i]=dp[j]+1;
            }
          maxx=max(dp[i],maxx);
        }
         printf("%d\n",maxx);

    }
    return 0;
}


POJ 2533-Longest Ordered Subsequence(dp_最长上升子序列)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43415309

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!