码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2828 Buy Tickets 万能的线段树大法。

时间:2015-02-03 09:37:13      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:acm   线段树   buy tickets   

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 14400   Accepted: 7199

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i ? 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

技术分享




我AC的状态:技术分享,,感觉不太满意,有点慢了,但是我比较懒,不想在改进了~~

说实话,这题从良心上说,弄懂了,真简单。但是我的弱项一直是线段树,所以就在拼命的刷线段树题,可是感觉长进不大。。囧 。。

解题思路:

观察发现,最后一个插入到该位置的人位置是固定的,那么我们可以从后面进行插入操作,pos ,val 代表val要插入到pos位置,那么就是说 pos 前面要留出 pos个位置,

因为 是从 0 开始的。

线段树 :st数组记录 该区间 目前还剩 x个空位,每一次 query即插入的时候 ,如果 该节点左儿子 x>=pos,那么只要在左儿子找就可以了

否则 要在右儿子中 找 ,此时 pos 改为 pos-左儿子空位。。


注意红体大字,,一开始就是没理解这句话,一直在死扣题目。如果弄懂了上面的两句话,那简直就是so easy啦!

下面代码:

#include <stdio.h>

#define MAX 200100

int st[MAX<<4],data[MAX];

void build(int left, int right ,int pos)
{
	if(left == right)
	{
		st[pos] = 1;
		return ;
	}
	int mid = (left+right)>>1 ;
	build(left,mid,pos<<1) ;
	build(mid+1,right,pos<<1|1) ;
	st[pos] = st[pos<<1]+st[pos<<1|1] ;
}

void update(int d , int x , int L , int R , int pos)
{
	if(R == L)
	{
		data[L] = d ;
		st[pos] = 0 ;
		return ;
	}
	int mid = (L+R)>>1 ;
	if(x<=st[pos<<1])
	{
		update(d,x,L,mid,pos<<1);
	}
	else
	{
		update(d,x-st[pos<<1],mid+1,R,pos<<1|1) ;
	}
	st[pos] = st[pos<<1]+st[pos<<1|1] ;
}

int main()
{
	int n,pos[MAX],val[MAX];
	while(~scanf("%d",&n))
	{
		build(1,n,1);
		for(int i = 0 ;i < n ; ++i)
		{
			scanf("%d%d",&pos[i],&val[i]) ;
		}
		for(int i = n-1 ; i >=0 ; --i)
		{
			update(val[i] , pos[i]+1 , 1 , n , 1);
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			printf("%d",data[i]);
			if(i != n)
			{
				printf(" ") ;
			}
		}
		printf("\n") ;
	}
	return 0 ;
}



poj 2828 Buy Tickets 万能的线段树大法。

标签:acm   线段树   buy tickets   

原文地址:http://blog.csdn.net/lionel_d/article/details/43417203

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!