码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu step 2.3.4)How Many Trees?(大数:求n个节点能够成多少棵二叉树)

时间:2015-02-03 19:30:43      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:

在写题解之前给自己打一下广告哈~技术分享。。抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下:

http://edu.csdn.net/course/detail/209


题目:

        

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 976 Accepted Submission(s): 511
 
Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 
Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 
Output
You have to print a line in the output for each entry with the answer to the previous question.
 
Sample Input
1
2
3
 
Sample Output
1
2
5
 



题目大意:

               给你一个n个节点,问能够成多少棵二叉树。

题目分析:

              简单题,只要知道有这个公式就好。卡特兰公式的一个应用就是用来求“给出n个节点,问能够成多少棵二叉树”。

an =C(2n,n)/(n+1)=(4n-2)*(an-1 )/(n+1)


先花O(n)时间打表,把前100项的结果全部算出来。以后就是O(1)的时间输出结果


代码如下:

import java.math.BigInteger;
import java.util.Scanner;


public class Main {
	
	
	public static void main(String[] args) {
		BigInteger catalans[] = new BigInteger[101];
		
		BigInteger four = new BigInteger("4");
		BigInteger two = new BigInteger("2");
		BigInteger one = new BigInteger("1");
		
		catalans[1] = new BigInteger("1");
		
		int i;
		for(i = 2 ; i <= 100 ; ++i){
			catalans[i] = catalans[i-1].multiply(four.multiply(BigInteger.valueOf(i)).subtract(two)).divide(BigInteger.valueOf(i+1));
		}
		
		
		Scanner scanner = new Scanner(System.in);
		while(scanner.hasNext()){
			int n = scanner.nextInt();
			System.out.println(catalans[n]);
		}
		
	}
}




(hdu step 2.3.4)How Many Trees?(大数:求n个节点能够成多少棵二叉树)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/43453075

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!