码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1251 统计难题 字典树水题

时间:2015-02-03 19:35:45      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:字典树   统计难题   hdu1251   acm   

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 19627    Accepted Submission(s): 8612


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
banana band bee absolute acm ba b band abc
 

Sample Output
2 3 1 0
大水题。就不分析了。
直接代码:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct Trie{
	int count;
	Trie *next[26];
};

void creat(Trie *t , char str[])
{
	int len = strlen(str) ;
	for(int i = 0 ; i < len ; ++i)
	{
		if(t->next[str[i]-'a'] == NULL)
		{
			Trie *temp = (Trie*)malloc(sizeof(Trie)) ;
			for(int j = 0 ; j < 26 ; ++j)
			{
				temp->next[j] = NULL;
			}
			temp->count = 0;
			t->next[str[i]-'a'] = temp ;
		}
		t = t->next[str[i]-'a'] ;
		++t->count ;
	}
}
int count = 0 ;
void query(Trie *t , char str[])
{
	int len = strlen(str) , i ;
	for(i = 0 ; i < len ; ++i)
	{
		if(t->next[str[i]-'a'] == NULL)
		{
			break ;
		}
		t = t->next[str[i]-'a'] ;
	}
	if( i == len)
	{
		count += t->count ;
	}
}

int main()
{
	int flag = 0;
	char str[20];
	Trie *t = (Trie *)malloc(sizeof(Trie)) ;
	for(int i = 0 ; i < 26 ; ++i)
	{
		t->next[i] = NULL ;
		t->count = 0 ;
	}
	while(gets(str))
	{
		if(strlen(str) == 0)
		{
			flag = 1 ;
			continue ;
		}
		if(!flag)
		{
			creat(t,str);
		}
		else
		{
			count = 0 ;
			query(t,str);
			printf("%d\n",count) ;
		}
	}
	return 0 ;
}


hdu 1251 统计难题 字典树水题

标签:字典树   统计难题   hdu1251   acm   

原文地址:http://blog.csdn.net/lionel_d/article/details/43452281

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!