码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3625 第一类斯特林数

时间:2015-02-03 23:05:37      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:数学基础

题目链接:click here

Examining the Rooms

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1146    Accepted Submission(s): 689


Problem Description
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
 

Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
 

Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
 

Sample Input
3 3 1 3 2 4 2
 

Sample Output
0.3333 0.6667 0.6250
分析: 看完这题第一想法是错排递推求解,WA了几发,后来发现会出现重复现象。

正解是第一类斯特林数:

第一类Stirling数 s(p,k)

s(p,k)的一个的组合数学解释是:将p个物体排成k个非空循环排列的方法数。

s(p,k)的递推公式: s(p,k)=(p-1)*s(p-1,k)+s(p-1,k-1) ,1<=k<=p-1

边界条件:s(p,0)=0 ,p>=1  s(p,p)=1  ,p>=0

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long ll;
ll stir[22][22];
ll jie[22];

void init()
{
  stir[1][0]=0;
  stir[1][1]=1;
  for(int i=2;i<=20;i++)
     for(int j=1;j<=i;j++)
        stir[i][j]=stir[i-1][j-1]+(i-1)*stir[i-1][j];
  jie[1]=1;
  for(int i=2;i<=20;i++)jie[i]=jie[i-1]*i;
}

int main()
{
   int T;
   scanf("%d",&T);
   init();
   while(T--)
   {
      int n,k;
      scanf("%d%d",&n,&k);
      ll ans=0;
      for(int i=1;i<=k;i++)
            ans+=stir[n][i]-stir[n-1][i-1];
      printf("%.4lf\n",ans*1.0/jie[n]);
   }
   return 0;
}


 

hdu 3625 第一类斯特林数

标签:数学基础

原文地址:http://blog.csdn.net/liusuangeng/article/details/43456117

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!