码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2438 Turn the corner(三分)

时间:2015-02-04 18:51:18      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:acm   algorithm   编程   三分   hdu   

Turn the corner

                                                        Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                       Total Submission(s): 2010    Accepted Submission(s): 765


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?
技术分享
 

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.
 

Sample Input
10 6 13.5 4 10 6 14.5 4
 

Sample Output
yes no
 



题意:
         给出街道在x轴的宽度X,y轴的宽度Y,还有车的长l和宽w,判断是否能够转弯成功。

题解:
        盗网上大牛一张图,画的很详细技术分享

      尽可能让车贴着外面的墙璧转弯,也就是图中的x轴和y轴,此时红线的方程就是图中的方程,此时p点的位置就是让y=X时解得的x值,要保证p点在Y内,也就是-x<y,假若在转弯的所有角度中都满足这个条件,那么就能转弯,分析得,-x先增大后减小,所以用三分求最大-x值。


代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const double pi=acos(-1.0);
const double eps=1e-6;
double x,y,l,w;
double solve(double angle)
{
    return (-x+l*sin(angle)+w/cos(angle))/tan(angle);
}
int main()
{
    while(~scanf("%lf%lf%lf%lf",&x,&y,&l,&w))
    {
        double l=0,r=pi/2,mid1,mid2;
        while(l+eps<r)
        {
            mid1=l+(r-l)/3;
            mid2=r-(r-l)/3;
            if(solve(mid1)>solve(mid2))
            r=mid2;
            else
            l=mid1;
        }
        if(solve(l)<y)
        printf("yes\n");
        else
        printf("no\n");
    }
    return 0;
}






hdu 2438 Turn the corner(三分)

标签:acm   algorithm   编程   三分   hdu   

原文地址:http://blog.csdn.net/caduca/article/details/43487677

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!