码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2251 三维广搜。

时间:2015-02-04 21:56:43      阅读:268      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   搜索   printf   math.h   

B - Dungeon Master
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.        

Is an escape possible? If yes, how long will it take?        

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).        
L is the number of levels making up the dungeon.        
R and C are the number of rows and columns making up the plan of each level.        
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#‘ and empty cells are represented by a ‘.‘. Your starting position is indicated by ‘S‘ and the exit by the letter ‘E‘. There‘s a single blank line after each level. Input is terminated by three zeroes for L, R and C.       

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).        

where x is replaced by the shortest time it takes to escape.        
If it is not possible to escape, print the line
Trapped!        

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

 

 

作为一个弱菜,被这道题卡了一天了。

三维广搜,六个方向,上下左右前后。

第一个案例可以理解为三个三层叠在一起的。

#include <stdio.h>
#include <string.h>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define M 45
#define inf 0x6ffffff
char map[M][M][M];
int vis[M][M][M];
int dir[6][3]={{0,1,0},{0,-1,0},{1,0,0},{-1,0,0},{0,0,1},{0,0,-1}};//六个方向
int n,m,ok,k;
struct node
{
	int x,y,z;
	int time;
}
;
node f[666];
int ztime;
int z2,x2,y2,z1,x1,y1;
void bfs()
{
	int i;
	queue<node>q;
	node st,ed;
	st.x=x1;
	st.y=y1;
    st.z=z1;
	st.time=0;
	q.push(st);
	while(!q.empty())
	{
		st=q.front();
		q.pop();
		if(st.x==x2 &&st.y==y2 &&st.z==z2)
		{
			ok=1;
			ztime=st.time;
			return;
		}
		for(i=0;i<6;i++)
		{
			ed.x=st.x+dir[i][0];
			ed.y=st.y+dir[i][1];
			ed.z=st.z+dir[i][2];
			if(map[ed.x][ed.y][ed.z]=='#' ||vis[ed.x][ed.y][ed.z] ||ed.x<0 ||ed.x>=k ||ed.y<0 ||ed.y>=n ||ed.z<0||ed.z>=m)//越界,搜过的地方,墙全部排除
				continue;
			ed.time=st.time+1;  //时间加一
			vis[ed.x][ed.y][ed.z]=1;
			q.push(ed);
		}
	}
	return;
}
int main()
{
	int i,j,r;
	while(scanf("%d%d%d",&k,&n,&m)!=EOF &&k!=0 &&n!=0 &&m!=0)
	{
		ok=0;
		memset(vis,0,sizeof(vis));
		for(i=0;i<k;i++)
			for(j=0;j<n;j++)  //我把j++写成i++找了一天的错误。。无语。
			{ 
				scanf("%s",map[i][j]);//输入地图
				for(r=0;r<m;r++)
				{
					if(map[i][j][r]=='S')
					{
						z1=r;
						x1=i;
						y1=j;
					}
					else if(map[i][j][r]=='E')
					{
						z2=r;
						x2=i;
						y2=j;
					}
				}
			}
			vis[x1][y1][z1]=1;
			bfs();
			//	printf("%d\n",ok);
			if(!ok)
				printf("Trapped!\n"); //后面有!。这里WA了一次。
			else
				printf("Escaped in %d minute(s).\n",ztime);//改了上面之后,这里后面有个点,又WA了一次。 ORZ。
	}
	return 0;
}


 

 

POJ 2251 三维广搜。

标签:acm算法   amp   搜索   printf   math.h   

原文地址:http://blog.csdn.net/sky_miange/article/details/43491359

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!