标签:hdu sg 博弈
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1536
Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
The players take turns chosing a heap and removing a positive number of beads from it.
The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:
Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
If the xor-sum is 0, too bad, you will lose.
Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
The player that takes the last bead wins.
After the winning player‘s last move the xor-sum will be 0.
The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0
< m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by
a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a ‘W‘.If the described position is a losing position print an ‘L‘. Print a newline after each test case.
Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
Sample Output
题意:
首先输入K 表示一个集合的大小 之后输入集合 ,表示对于这堆石子只能取这个集合中的某个元素的个数;
之后输入一个m 表示接下来对于这个集合要进行m次询问:
之后m行,每行输入一个n 表示有n个堆,每堆有n1个石子 问这一行所表示的状态是赢还是输 如果赢输入W否则L
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int s[117], sg[10017];
int n;//n是集合s的大小,S[i]是定义的特殊取法规则的数组
int SG_dfs(int x)
{
if(sg[x] != -1)
return sg[x];
int vis[117];
memset(vis,0,sizeof(vis));
for(int i = 0; i < n; i++)
{
if(x >= s[i])
{
SG_dfs(x-s[i]);
vis[sg[x-s[i]]] = 1;
}
}
int e;
for(int i = 0; ; i++)
{
if(!vis[i])
{
e=i;
break;
}
}
return sg[x] = e;
}
int main()
{
int m;
while(scanf("%d",&n)&&n)
{
for(int i = 0; i < n; i++)
scanf("%d",&s[i]);
memset(sg,-1,sizeof(sg));
sort(s,s+n);//从小到大
int num, t;
scanf("%d",&m);
for(int i = 0; i < m; i++)
{
scanf("%d",&t);
int ans = 0;
for(int j = 0; j < t; j++)
{
scanf("%d",&num);
ans^=SG_dfs(num);
}
if(ans == 0)
printf("L");
else
printf("W");
}
printf("\n");
}
return 0;
}
HDU S-Nim(博弈 SG)
标签:hdu sg 博弈
原文地址:http://blog.csdn.net/u012860063/article/details/43494747