码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 10340- All in All(字符串匹配)

时间:2015-02-05 09:32:31      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source: ULM Local Contest


题意:问第一个串是不是能在第二个串里找出来,不一定是连续的。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
const int inf=0x3f3f3f3f;
int main()
{
    string str1,str2;
    int i,j;
    while(cin>>str1>>str2){
        int len1=str1.length();
        int len2=str2.length();
        int cnt=0;
        i=j=0;
        while(i<len1&&j<len2){
            if(str1[i]==str2[j]){
                i++;
                j++;
                cnt++;
            }
            else
                j++;
        }
        //printf("i==%d  j==%d\n",i,j);
        //printf("cnt==%d\n",cnt);
        if(cnt==len1)
            printf("Yes\n");
        else
                printf("No\n");
    }
    return 0;
}


UVA 10340- All in All(字符串匹配)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43523521

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!