码迷,mamicode.com
首页 > 其他好文 > 详细

串 --- 匹配

时间:2014-06-03 12:03:57      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:des   c   style   class   blog   code   

All in All
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 27295   Accepted: 11162

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

 

【题目来源】

Ulm Local 2002

 

【题目大意】

给定一个a串和一个b串,现在要你判断a串是否出现在b串中。

 

【题目分析】

直接模拟也能过,暴力出奇迹啊,

 

bubuko.com,布布扣
#include<string.h>
#include<stdio.h>
char a[100010],b[100010];
int main()
{
    while(scanf("%s%s",a,b)!=EOF)
    {
        int len1=strlen(a),len2=strlen(b);
        if(len1>len2)
        {
            printf("No\n");continue;
        }
        int cnt=0;
        for(int i=0;i<len2;i++)
        {
            if(a[cnt++]==b[i])
                cnt++;
        }
        if(cnt==len1)
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}
bubuko.com,布布扣

其实这种做法是投机取巧的,数据太弱的题目能过,但是遇到数据强的就wa了。

 

 

 

 

串 --- 匹配,布布扣,bubuko.com

串 --- 匹配

标签:des   c   style   class   blog   code   

原文地址:http://www.cnblogs.com/acmer-jsb/p/3759950.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!