码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1689 Just a Hook 线段树区间更新求和

时间:2015-02-05 23:28:51      阅读:313      评论:0      收藏:0      [点我收藏+]

标签:


Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18894    Accepted Submission(s): 9483


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

技术分享


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1 10 2 1 5 2 5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source
 

屠夫的钩子长是n,且每个值都是1,可以使[a,b]区间的值变为c,求m次操作后,钩子的价值是多少。
线段树区间更新并且只求一次,在树的结构中加一个标志type表示此区间的值是type,在更新此区间的时候,同时也要更新此区间孩子的值。
//795MS	6224K
#include<stdio.h>
#include<algorithm>
#include<string.h>
#define M 100007
using namespace std;
struct node
{
    int l,r,mid,val,type;
}tree[M<<2];
int s[M];
void build(int left,int right,int i)//建树
{
    tree[i].l=left;tree[i].r=right;
    tree[i].mid=(left+right)>>1;tree[i].type=0;
    if(left==right){tree[i].val=1; return;}
    build(left,tree[i].mid,i*2);
    build(tree[i].mid+1,right,i*2+1);
    tree[i].val=tree[i*2].val+tree[i*2+1].val;
}
void update(int left,int right,int val,int i)
{
    if(tree[i].l>=left&&tree[i].r<=right){tree[i].val=(right-left+1)*val;tree[i].type=val; return;}
    else
    {
        if(tree[i].type)
        {
            tree[i*2].type=tree[i].type;
            tree[i*2].val=(tree[i*2].r-tree[i*2].l+1)*tree[i].type;
            tree[i*2+1].type=tree[i].type;
            tree[i*2+1].val=(tree[i*2+1].r-tree[i*2+1].l+1)*tree[i].type;
            tree[i].type=0;
        }
        if(tree[i].mid<left)update(left,right,val,2*i+1);
        else if(tree[i].mid>=right)update(left,right,val,2*i);
        else
        {
            update(left,tree[i].mid,val,2*i);
            update(tree[i].mid+1,right,val,2*i+1);
        }
        tree[i].val=tree[i*2].val+tree[i*2+1].val;
    }
}

int main()
{
    int n,m,t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        build(1,n,1);
        int a,b;
        int c;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas++,tree[1].val);
    }
}


HDU 1689 Just a Hook 线段树区间更新求和

标签:

原文地址:http://blog.csdn.net/crescent__moon/article/details/43538709

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!