码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 270-Lining Up(多点共线)

时间:2015-02-06 11:16:18      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

Lining Up
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享


 Lining Up 

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3

题意:问在给出的点中,最多有多少点在一条直线上。

Ps:一定要注意输入,真是坑哭了。UVA的格式错误返回的是WA saddd

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
using namespace std;
const int inf=0x3f3f3f3f;
struct node
{
    int x,y;
}q[1010];
char str[1010];
int main()
{
    int T,cnt,i,j,k;
    int sum,res;
    scanf("%d",&T);
    getchar();
    gets(str);
    while(T--){
        cnt=0;
        res=-inf;
        while(gets(str)){
            if(str[0]=='\0') break;
            sscanf(str,"%d %d",&q[cnt].x,&q[cnt].y);
            cnt++;
        }
        for(i=0;i<cnt;i++)
        for(j=i+1;j<cnt;j++){
            sum=2;
            for(k=j+1;k<cnt;k++)
                if((q[j].y-q[i].y)*(q[k].x-q[j].x)==(q[j].x-q[i].x)*(q[k].y-q[j].y))
                sum++;
            res=max(res,sum);
        }
        printf("%d\n",res);
        if(T)
            printf("\n");
    }
    return 0;
}


UVA 270-Lining Up(多点共线)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43561837

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!