码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1011 树形dp背包

时间:2015-02-06 20:34:53      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=1011

Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern‘s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1‘s.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
50 7
/**
hdu 1011  树形dp背包
题目大意:一棵树有n个节点,每个节点有一定的bug值和价值,一个人从1出发有m个兵(1个兵可以打20个bug),经过一个点
          要留下足够的兵才能往下走并且获得该点的价值,问如何用m个兵获得最大的价值
解题思路:背包问题。状态转移方程为:dp[u][j]=max(dp[u][j],dp[u][j-k]+dp[v][k]);(j:num~m;k:1~j-num;u为v的父亲节点)
          注意:房间bug数目为0,也要一个士兵。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=105;

int head[maxn],ip;
int n,m,dp[maxn][maxn],a[maxn],b[maxn];

struct note
{
    int v,next;
}edge[maxn*4];

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

void addedge(int u,int v)
{
    edge[ip].v=v,edge[ip].next=head[u],head[u]=ip++;
}

void dfs(int u,int pre)
{
     int num=(a[u]+19)/20;///获得该结点需要的士兵数目
     for(int i=num;i<=m;i++)
        dp[u][i]=b[u];
     for(int i=head[u];i!=-1;i=edge[i].next)
     {
         int v=edge[i].v;
         if(v==pre)continue;
         dfs(v,u);
         for(int j=m;j>=num;j--)
         {
             for(int k=1;k+num<=j;k++)
             {
                 dp[u][j]=max(dp[u][j],dp[u][j-k]+dp[v][k]);
             }
         }
     }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        init();
        for(int i=0;i<n-1;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        if(m==0)///这个必需要,有代价为0的房间,m=0则无法获得 
            puts("0");
        else
        {
            memset(dp,0,sizeof(dp));
            dfs(1,-1);
            printf("%d\n",dp[1][m]);
        }
    }
    return 0;
}


hdu1011 树形dp背包

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/43567801

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!