码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2054 Color a Tree 据说是贪心

时间:2015-02-06 21:55:57      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:poj2054   贪心   acm   数据结构   color a tree   

Color a Tree
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 7112   Accepted: 2438

Description

Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes. 

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try. 

Each node has a "coloring cost factor", Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi. 

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33. 
技术分享

Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.

Input

The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed. 

Output

For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.

Sample Input

5 1
1 2 1 2 4
1 2
1 3
2 4
3 5
0 0

Sample Output

33
	做完这道题之后,我是不得不佩服以为神牛,地址链接  ,在做这道题之前,,先把这篇博客看看,这里面证明贪心的可行性和怎么贪心。哎,,渣渣完全是被虐啊!!
	我得先平息一下自己心情,你们还是看这篇解析吧,点击打开链接,,说的不错!
	贪心始终是我内心无法言明的痛
下面是我的代码:
#include <stdio.h>
#define MAX 1010
struct Tree{
	int color,father,time;
	double weight;
}t[MAX];

int root;

int findMax(int n)
{
	double max = -1.0 ;
	int pos=0 ;
	for(int i = 1 ; i <= n ; ++i)
	{
		if(t[i].weight>max && i != root)
		{
			max = t[i].weight;
			pos = i;
		}
	}
	return pos ;
}

int main()
{
	int n;
	while(~scanf("%d%d",&n,&root) && (n||root))
	{
		int ans = 0 ;
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d",&t[i].color) ;
			t[i].time = 1 ;
			t[i].weight = t[i].color ;
			ans += t[i].color ;
		}
		for(int i = 1 ; i < n ; ++i)
		{
			int father,son;
			scanf("%d%d",&father,&son);
			t[son].father = father ;
		}
		for(int i = 1 ; i < n ; ++i)
		{
			int max = findMax(n) ;
			t[max].weight = 0.0;
			int f = t[max].father ;
			ans += t[f].time*t[max].color ;
			for(int j = 1 ; j <= n ; ++j)
			{
				if(t[j].father == max)
				{
					t[j].father = f ;
				}
			}
			t[f].color += t[max].color ;
			t[f].time += t[max].time ;
			t[f].weight = 1.0*t[f].color/t[f].time ;
		}
		printf("%d\n",ans) ;
	}
	return 0;
}


poj 2054 Color a Tree 据说是贪心

标签:poj2054   贪心   acm   数据结构   color a tree   

原文地址:http://blog.csdn.net/lionel_d/article/details/43568191

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!