码迷,mamicode.com
首页 > 其他好文 > 详细

poj1047 Round and Round We Go

时间:2015-02-07 09:11:11      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:poj

Round and Round We Go
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12064   Accepted: 5630

Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table: 
142857 *1 = 142857 
142857 *2 = 285714 
142857 *3 = 428571 
142857 *4 = 571428 
142857 *5 = 714285 
142857 *6 = 857142 

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.

Sample Input

142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

题意:给出一个字符串,如果这个字符串分别用1,2,...,len去乘,最终得到的结果还是由这个字符串的字符组成的,那么它是cyclic;

解题思路:给出的数*(len+1)=9...9(len个),那么这个数是cyclic

参考代码:

#include <iostream>
#include <string.h>
using namespace std;
char s[100];
int a[100];
int main(){
	while (cin>>s){
		int len=strlen(s);
		memset(a,0,sizeof(a));
		int k=0,left=0;
		for (int i=len-1;i>=0;i--){
			int ans=(s[i]-'0')*(len+1)+left;
			a[k++]=ans%10;
			left=ans/10;
		}
		while (left!=0){
			a[k++]=left%10;
			left/=10;
		}
		int flag=0;
		for (int i=0;i<k;i++){
			if (a[i]!=9){
				flag=1;
				break;
			}
		}
		if (flag==1)
			cout<<s<<" is not cyclic"<<endl;
		else
			cout<<s<<" is cyclic"<<endl;
	}
	return 0;
}



poj1047 Round and Round We Go

标签:poj

原文地址:http://blog.csdn.net/codeforcer/article/details/43576701

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!