码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1054 树形dp

时间:2015-02-07 20:23:14      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=1054

Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

技术分享 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
1 2
/**
hdu1054  树形dp
题目大意:给定一棵树求最小边覆盖的点数
解题思路:可以用二分图的最大匹配做,最大匹配数就是最小边覆盖。也可以树形dp:
           dp[u][0]表示以u为根节点的树u点不取的数目,dp[u][1]表示以u为根节点的树u点取的数目.
           状态转移方程:dp[u][0]+=dp[v][1];
                          dp[u][1]+=min(dp[v][0],dp[v][1]);
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1550;

int head[maxn],ip;
int dp[maxn][2],n;

struct note
{
    int v,next;
}edge[maxn*4];

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

void addedge(int u,int v)
{
    edge[ip].v=v,edge[ip].next=head[u],head[u]=ip++;
}

void dfs(int u,int pre)
{
    dp[u][1]=1;
    dp[u][0]=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(v==pre) continue;
        dfs(v,u);
        dp[u][0]+=dp[v][1];
        dp[u][1]+=min(dp[v][0],dp[v][1]);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=0;i<n;i++)
        {
            int u,k;
            scanf("%d:(%d)",&u,&k);
            u++;
            for(int j=0;j<k;j++)
            {
                int v;
                scanf("%d",&v);
                v++;
                addedge(u,v);
                addedge(v,u);
            }
        }
        memset(dp,0,sizeof(dp));
        dfs(1,-1);
        printf("%d\n",min(dp[1][0],dp[1][1]));
    }
    return 0;
}


hdu1054 树形dp

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/43606653

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!