码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 437 The Tower of Babylon DP

时间:2015-02-07 23:01:17      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:


有向图DAG

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions 技术分享 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values 技术分享 , 技术分享 and 技术分享 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Casecase: maximum height =height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

Source

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::Longest Increasing Subsequence (LIS)
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 5. Dynamic Programming 
Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 1. Algorithm Design :: Dynamic Programming :: Exercises: Beginner
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming :: Longest Increasing Subsequence (LIS)
Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 9. Dynamic Programming :: Examples



/* ***********************************************
Author        :CKboss
Created Time  :2015年02月07日 星期六 14时58分52秒
File Name     :UVA437.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=10010;

int n,nt;
struct Babylon
{
	int x,y,l;
}baby[maxn];

int dp[maxn];

bool check(int a,int b,int A,int B)
{
	if((a<A&&b<B)||(b<A&&a<B)) return true;
	return false;
}

int dfs(int x)
{
	if(dp[x]!=-1) return dp[x];
	
	int ret=baby[x].l;
	for(int i=0;i<n;i++)
	{
		if(check(baby[i].x,baby[i].y,baby[x].x,baby[x].y))
			ret=max(ret,baby[x].l+dfs(i));
	}

	dp[x]=ret;
	return ret;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int cas=1;
	while(scanf("%d",&nt)!=EOF&&nt)
	{
		n=0;
		for(int i=0;i<nt;i++)
		{
			int a[3]; for(int j=0;j<3;j++) scanf("%d",a+j);
			sort(a,a+3);
			baby[n++]=(Babylon){a[0],a[1],a[2]};
			baby[n++]=(Babylon){a[0],a[2],a[1]};
			baby[n++]=(Babylon){a[1],a[2],a[0]};
		}

		memset(dp,-1,sizeof(dp));
		int ans=0;
		for(int i=0;i<n;i++)
		{
			dfs(i);
			ans=max(ans,dp[i]);
		}
		printf("Case %d: maximum height = %d\n",cas++,ans);
	}
    
    return 0;
}



UVA 437 The Tower of Babylon DP

标签:

原文地址:http://blog.csdn.net/ck_boss/article/details/43612383

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!