标签:acm
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41840 Accepted: 22218
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
Source
Greater New York 2001
#include <stdio.h>
#include <string.h>
#define maxn 110
int N, g_result;
int G[maxn][maxn];
int max(int a, int b) { return a > b ? a : b; }
void solve(const int *numbers)
{
int result = numbers[1];
int currentSum = result;
for (int i = 2; i <= N; ++i) {
if (currentSum < 0) currentSum = 0;
currentSum += numbers[i];
result = max(result, currentSum);
}
g_result = max(g_result, result);
}
int main()
{
freopen("data.in", "r", stdin);
while (~scanf("%d", &N)) {
for (int i = 1; i <= N; ++i)
for (int j = 1; j <= N; ++j)
scanf("%d", &G[i][j]);
g_result = G[1][1];
for (int i = 1; i <= N; ++i) {
solve(G[i]);
for (int j = i + 1; j <= N; ++j) {
for (int k = 1; k <= N; ++k)
G[i][k] += G[j][k];
solve(G[i]);
}
}
printf("%d\n", g_result);
}
return 0;
}
标签:acm
原文地址:http://blog.csdn.net/chang_mu/article/details/43614679