码迷,mamicode.com
首页 > 其他好文 > 详细

南阳acm-72-Financial Management(水题)

时间:2015-02-08 08:59:12      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:

Financial Management

时间限制:3000 ms  |  内存限制:65535 KB
难度:1
 
描述
Larry graduated this year and finally has a job. He‘s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what‘s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
 
输入
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included. 
输出
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output. 
样例输入
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
样例输出
1581.42

AC代码:

#include<stdio.h>//自己编写 ,已经通过
int main()
{
float a1,a2,a3,a4,a5,a6,a7,a8,a9,a10,a11,a12,i,s;
scanf("%f",&a1);
scanf("%f",&a2);
scanf("%f",&a3);
scanf("%f",&a4);
scanf("%f",&a5);
scanf("%f",&a6);
scanf("%f",&a7);
scanf("%f",&a8);
scanf("%f",&a9);
scanf("%f",&a10);
scanf("%f",&a11);
scanf("%f",&a12);
s=a1+a2+a3+a4+a5+a6+a7+a8+a9+a10+a11+a12;
i=s/12;
printf("%.2f",i);
return 0;
}
#include<iostream>//最优解题代码
#include<iomanip>
using namespace std;
int main()
{
double sum=0,a;
for(int i=0;i<12;i++)
{
cin>>a;
sum+=a;
}
cout<<fixed<<setprecision(2)<<sum/12.0<<endl;
return 0;
}

 

南阳acm-72-Financial Management(水题)

标签:

原文地址:http://www.cnblogs.com/1san14/p/4279679.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!