标签:hdu1024 dp 动态规划 max sum plus plus
Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18131 Accepted Submission(s): 5931
Problem Description
Now I think you have got an AC in Ignatius.L‘s "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don‘t want to write a special-judge module, so you don‘t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
http://www.cnblogs.com/kuangbin/archive/2011/08/04/2127085.html
自己看吧。
#include <stdio.h>
#include <string.h>
#define INF 0x7fffffff
#define MAX 1000100
int dp[MAX] , num[MAX] , preMax[MAX];
int max(int a , int b)
{
return a>b?a:b ;
}
int main()
{
int m , n;
while(~scanf("%d%d",&m,&n))
{
for(int i = 1 ; i <= n ; ++i)
{
scanf("%d",&num[i]) ;
preMax[i] = 0 ;
dp[i] = 0 ;
}
dp[0] = 0 ;
preMax[0] = 0 ;
int mm ;
for(int i = 1 ; i <= m ; ++i)
{
mm = -INF;
for(int j = i ; j <= n ; ++j)
{
dp[j] = max(dp[j-1]+num[j],preMax[j-1]+num[j]) ;
preMax[j-1] = mm ;
mm = max(dp[j],mm) ;
}
}
printf("%d\n",mm) ;
}
return 0 ;
}
hdu1024 Max Sum Plus Plus
标签:hdu1024 dp 动态规划 max sum plus plus
原文地址:http://blog.csdn.net/lionel_d/article/details/43611507