码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1458 最长公共子序列

时间:2015-02-08 14:02:33      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40210   Accepted: 16188

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;

char str1[1001],str2[1001];
int dp[2][1001];
int l1,l2;

int main()
{
   // freopen("in.txt","r",stdin);
    while(~scanf("%s%s",str1,str2)){
        memset(dp,0,sizeof(dp));
        l1=strlen(str1);l2=strlen(str2);
        for(int i=0;i<l1;i++)
            for(int j=0;j<l2;j++)
        {
            if(str1[i]==str2[j])
                dp[(i+1)&1][j+1]=max(dp[i&1][j]+1,max(dp[(i+1)&1][j],dp[i&1][j+1]));
            else dp[(i+1)&1][j+1]=max(dp[i&1][j+1],dp[(i+1)&1][j]);
        }
        printf("%d\n",dp[l1&1][l2]);
    }
    return 0;
}

 

POJ 1458 最长公共子序列

标签:

原文地址:http://www.cnblogs.com/codeyuan/p/4279941.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!