码迷,mamicode.com
首页 > 其他好文 > 详细

一道编程题实在是不知道哪个地方错了

时间:2015-02-09 09:33:46      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:

求帮忙
       一道觉得很简单的编程题,提交了很多次,但是,还是wrong,实在是崩溃啊,真的不知道哪里错了,希望大家可以帮忙解决一下,感激不尽。
就是这道题————Conversions

Description

Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

Type Metric English equivalent
Weight 1.000 kilograms 2.2046 pounds
Weight 0.4536 kilograms 1.0000 pound
Volume 1.0000 liter 0.2642 gallons
Volume 3.7854 liters 1.0000 gallon

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input

5
1 kg
2 l
7 lb
3.5 g
0 l

Sample Output

1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g
 下面是我的代码,求帮忙
#include<stdio.h>
#include <string.h>  
int main()
{
	int n, i, count;
	char a[1001];
	double result, x;
	while(~scanf("%d", &n))
	{
		for(i=0;i<n;i++)
		{
			scanf("%lf %s", &x, a);
			if(strcmp(a, "kg")==0)
			{
				result=2.2046*x;
				printf("%d %.4f lb\n", i+1, result);
			}
			else if(strcmp(a, "lb")==0)
			{
				result=0.4536*x;
				printf("%d %.4f kg\n", i+1, result);
			}
			else if(strcmp(a, "l")==0)
			{
				result=0.2642*x;
				printf("%d %.4f g\n", i+1, result);
			}
			else if(strcmp(a, "g")==0)
			{
				result=3.7854*x;
				printf("%d %.4f l\n", i+1, result);
			}
		}
	}
	return 0;
}

希望大家可以帮帮忙,先谢谢了。


一道编程题实在是不知道哪个地方错了

标签:

原文地址:http://blog.csdn.net/unusualnow/article/details/43647059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!