标签:
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158949 Accepted Submission(s): 37195
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
Author
Ignatius.L
这个是回顾一下,之前不会。。现在知道了……
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int a[100000];
int main()
{
int T,N,i;
int count=1;
cin>>T;
while(T--)
{
memset(a,0,sizeof(a));
int sum=0;
int max=-1001;
int start=1,k=1,end=1;
cin>>N;
for(i=0;i<N;i++)
cin>>a[i];
for(i=0;i<N;i++)
{
sum=sum+a[i];
if(sum>max)
{ max=sum;
start=k;
end=i+1;
}
if(sum<0)
{
k=i+2;
sum=0;
}
}
printf("Case %d:\n",count++);
printf("%d %d %d\n",max,start,end);
if(T!=0)
cout<<endl;
}
return 0;
}
????Max Sum
标签:
原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/43669729