码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3279 Fliptile

时间:2015-02-09 16:02:14      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:poj   acm   编程   

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 3810   Accepted: 1457

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0


题意:

       二维翻转,翻转一块土地的位置,同时它的上下左右也要翻转,如何翻转,能使土地全为0,输出最小翻转方案。


题解:

        首先要明白,每个位置只能翻转一次(因为翻转2次等于没有翻转),接着枚举第1行的翻转情况,根据第1行的翻转情况就可以推出第1行的土地情况,然后就可以根据第1行的土地情况往下推,上一行土地为1,这块土地必须翻转,为0,这块土地不能翻转,最后再判断最后一行是否全为0就可以了。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=18;
int n,m;
int a[maxn][maxn],b[maxn][maxn],ans[maxn][maxn];
int check(int x)
{
    for(int i=0;i<m;i++)
    {
        if(x&(1<<i))
        {
           ans[0][i]=1;
           b[0][i]^=1;
           if(i>0)
           b[0][i-1]^=1;
           if(i+1<m)
           b[0][i+1]^=1;
           if(n>1)
           b[1][i]^=1;
        }
    }
    for(int i=1;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(b[i-1][j])
            {
                b[i-1][j]=0;
                ans[i][j]=1;
                b[i][j]^=1;
                if(i+1<n)
                b[i+1][j]^=1;
                if(j>0)
                b[i][j-1]^=1;
                if(j+1<m)
                b[i][j+1]^=1;
            }
        }
    }
    for(int j=0;j<m;j++)
        if(b[n-1][j])
           return false;
    return true;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int sign=0;
        for(int i=0;i<n;i++)
          for(int j=0;j<m;j++)
             scanf("%d",&a[i][j]);
        for(int i=0;i<(1<<m);i++)
        {
            memcpy(b,a,sizeof(a));
            memset(ans,0,sizeof(ans));
            if(check(i))
            {
                sign=1;
                for(int j=0;j<n;j++)
                {
                    for(int k=0;k<m-1;k++)
                    {
                        printf("%d ",ans[j][k]);
                    }
                    printf("%d\n",ans[j][m-1]);
                }
                break;
            }
        }
        if(sign==0)
        printf("IMPOSSIBLE\n");
    }
    return 0;
}


POJ 3279 Fliptile

标签:poj   acm   编程   

原文地址:http://blog.csdn.net/caduca/article/details/43671267

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!