码迷,mamicode.com
首页 > 其他好文 > 详细

Terrible Sets

时间:2014-05-31 22:01:28      阅读:325      评论:0      收藏:0      [点我收藏+]

标签:des   c   style   class   blog   code   

Terrible Sets
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3017   Accepted: 1561

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it‘s difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+...+wnhn < 109.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

bubuko.com,布布扣
#include"iostream"
#include"stack"
#include"cstdio"
using namespace std;
struct abc
{
    int w;
    int h;
} data;
int main()
{
    int lasth,n,i,ans,curarea,totalw;
    while(cin>>n&&n!=-1)
    {
        stack<abc> s;
        ans=0;
        lasth=0;
        for(i=0;i<n;i++)
        {
            cin>>data.w>>data.h;
            if(data.h>=lasth)
            {
                lasth=data.h;
                s.push(data);
            }
            else
            {
                totalw=0;
                curarea=0;
                while(!s.empty()&&s.top().h>=data.h)
                {
                    totalw+=s.top().w;
                    curarea=totalw*s.top().h;
                    if(curarea>ans)
                       ans=curarea;
                    s.pop();  
                }
                totalw+=data.w;
                data.w=totalw;
                s.push(data);
            } 
        }
        totalw=0;
        curarea=0;
        while(!s.empty())
        {
            totalw+=s.top().w;
            curarea=totalw*s.top().h;
            if(curarea>ans)
                ans=curarea;
            s.pop();   
        }  
        cout<<ans<<endl;
    }
    return 0;
}
bubuko.com,布布扣

 

Terrible Sets,布布扣,bubuko.com

Terrible Sets

标签:des   c   style   class   blog   code   

原文地址:http://www.cnblogs.com/767355675hutaishi/p/3760929.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!