码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2312 Battle City(优先队列+BFS)

时间:2015-02-09 23:08:15      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://poj.org/problem?id=2312

Battle City
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7085   Accepted: 2390

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 
技术分享

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 
技术分享

Your tank can‘t move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of ‘Y‘ (you), ‘T‘ (target), ‘S‘ (steel wall), ‘B‘ (brick wall), ‘R‘ (river) and ‘E‘ (empty space). Both ‘Y‘ and ‘T‘ appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can‘t arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8
题意:求从Y到T最少花费多长时间。

题解: 首先求最短时间,用BFS。又因为各点的权值可能不一样,所以需要优先队列~~

PS:第一次用STL里的优先队列,好方便!!!

AC代码:

#include<iostream>
#include<cstring>
#include<queue>
#define N 305
using namespace std;
int n,m,sx,sy,ex,ey,visit[N][N];
int dir[][2]={
    {0,1},{0,-1},{1,0},{-1,0}
};
char chess[N][N];
struct Node{
    int x,y,s;
    friend bool  operator <(Node a,Node b ){
        return a.s>b.s;
    }
};
bool ok(int x,int y){
    if(x>=0&&x<m&&y>=0&&y<n&&chess[x][y]!='S'&&chess[x][y]!='R')
        return true;
    return false;
}
int bfs(){
    priority_queue<Node> q;
    memset(visit,-1,sizeof(visit));
    visit[sx][sy]=0;
    Node head={sx,sy,0};
    q.push(head);
    while(!q.empty())
    {
        Node f=q.top();
        q.pop();
        if(f.x==ex&&f.y==ey)return f.s;
        for(int i=0;i<4;i++){
            int dx=f.x+dir[i][0],dy=f.y+dir[i][1];
            if(ok(dx,dy)&&visit[dx][dy]){
                visit[dx][dy]=0;
                int temp=0;
                if(chess[dx][dy]=='B')temp=2;
                else temp=1;
                Node tmp={dx,dy,f.s+temp};
                q.push(tmp);
            }
        }
    }
    return -1;
}
int main()
{
    cin.sync_with_stdio(false);
    while(cin>>m>>n&&(m||n))
    {
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++){
                cin>>chess[i][j];
                if(chess[i][j]=='Y'){
                    sx=i;sy=j;
                    chess[i][j]='S';
                }
                else if(chess[i][j]=='T'){
                    ex=i;ey=j;
                }
            }
        cout<<bfs()<<endl;
    }
    return 0;
}

【转载请注明出处】

作者: MummyDing

出处:http://blog.csdn.net/mummyding/article/details/43676441



POJ 2312 Battle City(优先队列+BFS)

标签:

原文地址:http://blog.csdn.net/mummyding/article/details/43676441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!