码迷,mamicode.com
首页 > 其他好文 > 详细

YT14-HDU-求1/n的第m位数

时间:2015-02-10 00:43:33      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:c++   iostream   namespace   博客   编程   

Problem Description

Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed

Input

Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)

Output

For each line of input, your program should print a numble on a line,according to the above rules

Sample Input

4 2
5 7
123 123

Sample Output

5
0
8

Author

YBB

Source

HDU 2007-10 Programming Contest_WarmUp

代码如下:

#include <iostream>
using namespace std;
int main()
{
    int n,m,i,s,t;
    while(cin>>n>>m)
    {
        if(m==1)
            cout<<0<<endl;
        else
        {
            s=10;
            for(i=1; i<=m; i++)
            {

                t=s/n;
                s=s%n*10;
            }
            cout<<t<<endl;
        }
    }
    return 0;
}





YT14-HDU-求1/n的第m位数

标签:c++   iostream   namespace   博客   编程   

原文地址:http://blog.csdn.net/liuchang54/article/details/43680327

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!