标签:c++ iostream namespace 博客 编程
Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
Output
For each line of input, your program should print a numble on a line,according to the above rules
Sample Input
Sample Output
Author
YBB
Source
HDU 2007-10 Programming Contest_WarmUp
代码如下:
#include <iostream>
using namespace std;
int main()
{
int n,m,i,s,t;
while(cin>>n>>m)
{
if(m==1)
cout<<0<<endl;
else
{
s=10;
for(i=1; i<=m; i++)
{
t=s/n;
s=s%n*10;
}
cout<<t<<endl;
}
}
return 0;
}
YT14-HDU-求1/n的第m位数
标签:c++ iostream namespace 博客 编程
原文地址:http://blog.csdn.net/liuchang54/article/details/43680327