码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 2952 Counting Sheep

时间:2015-02-10 00:42:44      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:简单dfs

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2952

Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2231    Accepted Submission(s): 1474


Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I‘d gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
技术分享


Creative as I am, that wasn‘t going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I‘ve got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I‘ve decided I need another computer program that does the counting for me. Then I‘ll be able to just start both these programs before I go to bed, and I‘ll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
6 3
 

Source
 

题意:给你一个图,算出有都少个“#”快。

题解:递归标记一些就好了....DFS都不用回溯。

AC代码:

#include<iostream>
#include<string>
#define N 105
using namespace std;
string str[N];
int t,m,n;
int dir[][2]={
    {0,1},{0,-1},{1,0},{-1,0}
};
void dfs(int x,int y ){
    for(int i=0;i<4;i++){
        int dx=x+dir[i][0],dy=y+dir[i][1];
        if(dx>=0&&dx<m&&dy>=0&&dy<n&&str[dx][dy]=='#'){
            str[dx][dy]='.';
            dfs(dx,dy);
        }
    }
}
int main()
{
    cin.sync_with_stdio(false);
    cin>>t;
    while(t--){
        int sum=0;
        cin>>m>>n;
        for(int i=0;i<m;i++)cin>>str[i];
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            if(str[i][j]=='#'){
            sum++;
            str[i][j]='.';
            dfs(i,j);
        }
        cout<<sum<<endl;
    }

    return 0;
}






HDOJ 2952 Counting Sheep

标签:简单dfs

原文地址:http://blog.csdn.net/mummyding/article/details/43680241

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!