码迷,mamicode.com
首页 > 其他好文 > 详细

FatMouse' Trade

时间:2015-02-10 16:47:29      阅读:94      评论:0      收藏:0      [点我收藏+]

标签:

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47476    Accepted Submission(s): 16005


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

Author
CHEN, Yue
#include<iostream>
#include<algorithm>
using namespace std;
struct room
{
    int catfood;
    int mousefood;
    double danwei;
};
int cmp(room a,room b)
{
       return a.danwei>b.danwei;
}
int main()
{
    int M,N,i;
    room a[1000];
    while(scanf("%d%d",&M,&N))
    {
        double sum=0;
        if(M==-1 && N==-1)
            break;
        for(i=0;i<N;i++)
        {
            cin>>a[i].mousefood>>a[i].catfood;
        }
        for(i=0;i<N;i++)
           a[i].danwei=a[i].mousefood*1.0/a[i].catfood;//单位猫食,获得的物品量
        sort(a,a+N,cmp);//降序排列
        i=0;
        while(i<N && a[i].catfood<=M)
        {
            sum=sum+a[i].mousefood;
            M=M-a[i].catfood;
            i++;
        }
        if(i==N)
        {
            printf("%.3lf\n",sum);//准备的猫食可能有剩余
        }
        else
        {
            sum=sum+a[i].mousefood*M*1.0/a[i].catfood;//此时准备的猫食以花干
            printf("%.3lf\n",sum);
        }    
    }
    return 0;
}

FatMouse' Trade

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/43704413

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!