码迷,mamicode.com
首页 > 其他好文 > 详细

ACboy needs your help(DP)

时间:2015-02-11 09:24:11      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:dp

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4542    Accepted Submission(s): 2431



Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
3 4 6 题意: 题目给出n个课程和m天,问如何安排m天的课程使得最后的收益达到最大值. 题解: 简单DP,以dp[i]表示当前安排i天可以获得的最大收益,则可以得出状态转移方程dp[k + j] = max(dp[k + j], dp[k] + a[i][j]); 表示当前的课程安排j天的最 优解. 具体看下代码吧! AC代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
#include <map>
#include <set>
#define eps 1e-9

using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int M = 200;
const int INF = 0x3f3f3f3f;
const int mod = 10000007;
int maxn[M][M],dp[M],tp[M];

int main(){
    //freopen("in","r",stdin);
    int n,m;
    while(~scanf("%d %d",&n,&m) && (n | m)){
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= m; j++){
                scanf("%d",&maxn[i][j]);
            }
        }
        for(int i = 1; i <= m; i++) dp[i] = maxn[1][i]; //初始化
        for(int i = 2; i <= n; i++){
            for(int k = 1; k <= m; k++) tp[k] = dp[k]; //防止当前的状态会覆盖之前的值,所以先把最优值保存在tp数组中;
            for(int j = 1; j <= m; j++){
                for(int k = 0; k + j <= m; k++){
                    tp[k + j] = max(tp[k + j],dp[k] + maxn[i][j]);
                }
            }
            for(int k = 1; k <= m; k++) dp[k] = max(tp[k],dp[k]);
        }
        int Max = 1;
        for(int i = 2; i <= m; i++)
            if(dp[Max] < dp[i]) Max = i;
        printf("%d\n",dp[Max]);
    }
    return 0;
}


ACboy needs your help(DP)

标签:dp

原文地址:http://blog.csdn.net/zsgg_acm/article/details/43709579

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!