码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2639 Bone Collector II 01背包问题 求第K大最优值。。

时间:2015-02-11 09:25:32      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:hdu2639   bone collector i   acm   dp   01背包   

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2665    Accepted Submission(s): 1392


Problem Description
The title of this problem is familiar,isn‘t it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven‘t seen it before,it doesn‘t matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

Sample Input
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
12 2 0
这样的问题,背包九讲里提到过。不行的去这个博客看吧。http://www.2cto.com/kf/201305/214139.html 不过我感觉我的代码比他写的清楚。
#include <cstdio>
#include <cstring>
#define MAX 1100
using namespace std ;
int dp[MAX][40],value[MAX],volume[MAX] , t1[40],t2[40];

int main()
{
	int c;
	scanf("%d",&c) ;
	while(c--)
	{
		int n , v , k ;
		scanf("%d%d%d",&n,&v,&k) ;
		for(int i = 0 ; i < n  ; ++i)
		{
			scanf("%d",&value[i]) ;
		}
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&volume[i]) ;
		}
		memset(dp,0,sizeof(dp)) ;
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = v ; j >= volume[i] ; --j)
			{
				for(int m = 1 ; m <= k ; ++m)
				{
					t1[m] = dp[j][m] ;
					t2[m] = dp[j-volume[i]][m] + value[i];
				}
				t1[k+1] = t2[k+1] = -1 ;
				int a = 1, b = 1 ;
				//下面是合并。 
				for(int m = 1 ; (a<=k||b<=k)&&m <= k ;)
				{
					if(t1[a]>t2[b])	dp[j][m] = t1[a++] ;
					else
					{
						dp[j][m] = t2[b++] ;
					}
					if(dp[j][m] != dp[j][m-1])	++m ;
				}
			}
		}
		printf("%d\n",dp[v][k]) ;
	}
	return 0 ;
}


hdu 2639 Bone Collector II 01背包问题 求第K大最优值。。

标签:hdu2639   bone collector i   acm   dp   01背包   

原文地址:http://blog.csdn.net/lionel_d/article/details/43709501

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!