标签:acm hdu
Nth Largest Value
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1140 Accepted Submission(s): 892
Problem Description
For this problem, you will write a program that prints the Nth largest value in a fixed sized array of integers. To make things simple, N will be 3 and the array will always be have 10 decimal integer values.
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set consists of a single line containing the data set number, followed by a space,followed by 10 space
separated decimal integers whose values are between 1 and 1000 inclusive.
Output
For each data set, generate one line of output with the following values: The data set number as a decimal integer, a space, and the 3rd largest value of the corresponding 10 integers.
Sample Input
4
1 1 2 3 4 5 6 7 8 9 1000
2 338 304 619 95 343 496 489 116 98 127
3 931 240 986 894 826 640 965 833 136 138
4 940 955 364 188 133 254 501 122 768 408
Sample Output
Source
AC代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int a[15];
int main() {
int P, tmp;
scanf("%d", &P);
while(P--) {
scanf("%d", &tmp);
for(int i=0; i<10; i++ ){
scanf("%d", &a[i]);
}
sort(a, a+10);
printf("%d %d\n", tmp, a[7]);
}
return 0;
}
HDU- 3279 - Nth Largest Value
标签:acm hdu
原文地址:http://blog.csdn.net/u014355480/article/details/43741975