码迷,mamicode.com
首页 > 其他好文 > 详细

Face The Right Way poj 3276 开关问题

时间:2015-02-12 09:21:44      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:face the right way   poj 3276   开关问题   farmer john   

Language:
Face The Right Way
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 2811   Accepted: 1298

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N 
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source


题意:n头牛站成一列,每头牛或者向前或者向后,要求通过转向让所有的牛都面向前方,使K头连续的牛转向为一次操作,求最小的操作次数M和对应的K。开关问题

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 5005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
typedef long long ll;
using namespace std;

int dir[maxn]; //牛的方向
int f[maxn];   //区间[i,i+k-1]是否进行翻转
int n;
char str[5];

int calc(int k)
{
    memset(f,0,sizeof(f));
    int ans=0;
    int sum=0;  //f的和
    for (int i=0;i+k<=n;i++)
    {
        //计算区间[i,i+k-1]
        if ((sum+dir[i])%2!=0)  //前端的牛朝后方
        {
            f[i]=1;
            ans++;
        }
        sum+=f[i];
        if (i-k+1>=0)
            sum-=f[i-k+1];
    }
    //检查后方的牛是否有面朝后方的情况
    for (int i=n-k+1;i<n;i++)
    {
        if ((sum+dir[i])%2!=0)
            return -1;
        if (i-k+1>=0)
            sum-=f[i-k+1];
    }
    return ans;
}

void solve()
{
    int K=1,M=n;
    for (int i=1;i<=n;i++)
    {
        int m=calc(i);
        if (m>=0&&m<M)
        {
            K=i;
            M=m;
        }
    }
    printf("%d %d\n",K,M);
}

int main()
{
    while (~scanf("%d",&n))
    {
        memset(dir,0,sizeof(dir));
        for (int i=0;i<n;i++)
        {
            scanf("%s",str);
            if (str[0]=='B') dir[i]=1;
        }
        solve();
    }
    return 0;
}



Face The Right Way poj 3276 开关问题

标签:face the right way   poj 3276   开关问题   farmer john   

原文地址:http://blog.csdn.net/u014422052/article/details/43741569

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!