码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1059 Dividing DP,多重背包 测试数据很水

时间:2015-02-12 09:24:41      阅读:459      评论:0      收藏:0      [点我收藏+]

标签:hdu1059   dividing   多重背包   acm   dp   

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18691    Accepted Submission(s): 5214


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0‘‘. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0‘‘; do not process this line.
 

Output
For each colletcion, output ``Collection #k:‘‘, where k is the number of the test case, and then either ``Can be divided.‘‘ or ``Can‘t be divided.‘‘.

Output a blank line after each test case.
 

Sample Input
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
Collection #1: Can‘t be divided. Collection #2: Can be divided.
这道题很有趣呵呵
你们看我的AC状态:
技术分享
你再看看题目要求的时间。
我这代码过不过就是看人品吧。
我按照讨论区里面说的,,改进了一下,再看一下AC状态:
技术分享
我有两份代码,
这份是982MS的:
#include <stdio.h>
#include <string.h>
#define MAX 401000

int dp[MAX] ;

int max(int a , int b)
{
	return a>b?a:b;
}

void zeroOnePack(int value , int total)
{
	for(int i = total ; i >= value ; --i)
	{
		dp[i] =max(dp[i] , dp[i-value] + value) ;
	}
}

void completePack(int value , int total)
{
	for(int i = value ; i <= total ; ++i)
	{
		dp[i] = max(dp[i] , dp[i-value] + value) ;
	}
}

void multiplePack(int value , int count , int total)
{
	if(count*value > total)
	{
		completePack(value , total) ;
	}
	else
	{
		int k = 1 ;
		while(k<=count)
		{
			zeroOnePack(k*value , total);
			count -= k ;
			k  *= 2 ;
		}
		zeroOnePack(count*value , total);
	}
}

int main()
{
	int count[10] , c = 1;
	while(true)
	{
		int total = 0 ;
		bool flag = false ;
		for(int i = 1 ; i <= 6 ; ++i)
		{
			scanf("%d",&count[i]) ;
			if(count[i] != 0)
			{
				flag = true ;
			}
			total += count[i]*i ;
		}
		if(!flag) break ;
		printf("Collection #%d:\n",c++) ;
		if(total%2 == 1) 
		{
			printf("Can't be divided.\n\n");
			continue ;
		}
		memset(dp,0,sizeof(int)*(total/2+10)) ;
		for(int i = 1 ; i <= 6 ; ++i)
		{
			multiplePack(i , count[i] , total/2) ;
		}
		if(dp[total/2] == total/2)	
			printf("Can be divided.\n\n") ;
		else	printf("Can't be divided.\n\n");
	}
	return 0 ;
}

这份是0MS的:
#include <stdio.h>
#include <string.h>

#define MAX 401000

int dp[MAX] ;

int max(int a , int b)
{
	return a>b?a:b;
}

void zeroOnePack(int value , int total)
{
	for(int i = total ; i >= value ; --i)
	{
		dp[i] =max(dp[i] , dp[i-value] + value) ;
	}
}

void completePack(int value , int total)
{
	for(int i = value ; i <= total ; ++i)
	{
		dp[i] = max(dp[i] , dp[i-value] + value) ;
	}
}

void multiplePack(int value , int count , int total)
{
	if(count*value > total)
	{
		completePack(value , total) ;
	}
	else
	{
		int k = 1 ;
		while(k<=count)
		{
			zeroOnePack(k*value , total);
			count -= k ;
			k  *= 2 ;
		}
		zeroOnePack(count*value , total);
	}
}

int main()
{
	int count[10] , c = 1;
	while(true)
	{
		int total = 0 ;
		bool flag = false ;
		for(int i = 1 ; i <= 6 ; ++i)
		{
			scanf("%d",&count[i]) ;
			if(count[i] != 0)
			{
				flag = true ;
			}
			count[i] %= 30 ;
			total += count[i]*i ;
		}
		if(!flag) break ;
		printf("Collection #%d:\n",c++) ;
		if(total%2 == 1) 
		{
			printf("Can't be divided.\n\n");
			continue ;
		}
		memset(dp,0,sizeof(int)*(total/2+10)) ;
		for(int i = 1 ; i <= 6 ; ++i)
		{
			multiplePack(i , count[i] , total/2) ;
		}
		if(dp[total/2] == total/2)	
			printf("Can be divided.\n\n") ;
		else	printf("Can't be divided.\n\n");
	}
	return 0 ;
}


我只做了一点小小的修改,就是把每个value给模30。其实第一份代码可以不通过模30而改进的,,把所有函数写进主函数里可能就减少了耗时。(Ps:我在写博客的时候,又试了一下第一份代码,,变成了600MS,第一份代码应该是肯定能过的代码)。

hdu 1059 Dividing DP,多重背包 测试数据很水

标签:hdu1059   dividing   多重背包   acm   dp   

原文地址:http://blog.csdn.net/lionel_d/article/details/43739905

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!