码迷,mamicode.com
首页 > 其他好文 > 详细

dfs+bfs poj 3038

时间:2015-02-12 10:43:47      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:

Children of the Candy Corn
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10331   Accepted: 4466

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. 

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there‘s no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn‘t work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.) 

As the proprieter of a cornfield that is about to be converted into a maze, you‘d like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks (‘#‘), empty space by periods (‘.‘), the start by an ‘S‘ and the exit by an ‘E‘. 

Exactly one ‘S‘ and one ‘E‘ will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls (‘#‘), with the only openings being the ‘S‘ and ‘E‘. The ‘S‘ and ‘E‘ will also be separated by at least one wall (‘#‘). 

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the ‘S‘ and ‘E‘) for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

Source

 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
using namespace std;
queue<int> q;
int tt,n,m,sx,sy,ex,ey,cnt;
bool flag,vis[50][50];
int dic[4][2]={{0,-1},{-1,0},{0,1},{1,0}};
char s[50][50];
bool check(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    return true;
}
void dfs(int x,int y,int xx,int yy,int d)
{
    if(x==xx&&y==yy)
    {
        flag=1;
        return ;
    }
    d=(d+3)%4;
    for(int i=d;i<d+4;i++)
    {
        int tx,ty;
        tx=x+dic[i%4][0],ty=y+dic[i%4][1];
        if(!check(tx,ty)||s[tx][ty]==‘#‘) continue;
        cnt++;
        dfs(tx,ty,xx,yy,i%4);
        if(flag)
            return ;
    }
}

int bfs()
{
    int step,x,y,xx,yy;
    while(!q.empty()) q.pop();
    q.push(sx),q.push(sy),q.push(1);
    vis[sx][sy]=1;
    while(!q.empty())
    {
        x=q.front(),q.pop();
        y=q.front(),q.pop();
        step=q.front(),q.pop();
        if(x==ex&&y==ey)
            return step;
        for(int i=0;i<4;i++)
        {
            xx=x+dic[i][0];
            yy=y+dic[i][1];
            if(!check(xx,yy)||vis[xx][yy]||s[xx][yy]==‘#‘) continue;
            q.push(xx),q.push(yy),q.push(step+1);
            vis[xx][yy]=1;
        }
    }
}
int main()
{
    scanf("%d",&tt);
    while(tt--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&m,&n);
        for(int i=0;i<n;i++)
            scanf("%s",s[i]);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(s[i][j]==‘S‘)
                    sx=i,sy=j;
                if(s[i][j]==‘E‘)
                    ex=i,ey=j;
            }
        }
        cnt=1;
        flag=0;
        dfs(sx,sy,ex,ey,0);
        printf("%d",cnt);
        cnt=1;
        flag=0;
        dfs(ex,ey,sx,sy,0);
        printf(" %d",cnt);
        printf(" %d\n",bfs());
    }
    return 0;
}

  

dfs+bfs poj 3038

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4287436.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!