码迷,mamicode.com
首页 > 其他好文 > 详细

A hard puzzle

时间:2015-02-12 16:17:46      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32334    Accepted Submission(s): 11562


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b‘s last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 

Author
eddy
思路:可以多举几个例子,然后可以归纳一下,例如
7的1次方末尾数是7
7的2次方末尾数是9,
7的3次方末尾数是3,
7的4次方末尾数是1,
7的5次方末尾数是7,
……可以周期为4,如果你要说如果是1的几次方呢,周期不是1吗,怎么办,没关系,因为无论举哪一个数,最大的周期都为4,所以都可以看成周期为4的来算。
下面是我之前的代码,交两次wrong anwer,然后问了一下百度,得知是a,如果很大,c[0]*a,或者c[1]*a等待,可能会溢出,所以又加以修改。
错误代码如下:
#include<iostream>//1097
#include<algorithm>
using namespace std;
int main()
{	int a,b,c[4]; 
  while(cin>>a>>b)  
  {	 
	  c[0]=a%10;//一次方的末尾数	
     c[1]=(c[0]*a)%10;//二次方的末尾数
	 c[2]=(c[1]*a)%10;//三次方的末尾数
	 c[3]=(c[2]*a)%10;//四次方的末尾数	
	 if(b%4==1)		
		 cout<<c[0]<<endl;
	 if(b%4==2)	
		 cout<<c[1]<<endl;
	 if(b%4==3)		 
		 cout<<c[2]<<endl;
	 if(b%4==0)		 
		 cout<<c[3]<<endl; 
  }	
  return 0;
}

经过改正之后。
正确代码是:
#include<iostream>//1097
#include<algorithm>
using namespace std;
int main()
{    int a,b,c[4]; 
  while(cin>>a>>b)  
  {     
      a=a%10;
      c[0]=a;//一次方的末尾数    
     c[1]=(c[0]*a)%10;//二次方的末尾数
     c[2]=(c[1]*a)%10;//三次方的末尾数
     c[3]=(c[2]*a)%10;//四次方的末尾数    
     if(b%4==1)        
         cout<<c[0]<<endl;
     if(b%4==2)    
         cout<<c[1]<<endl;
     if(b%4==3)         
         cout<<c[2]<<endl;
     if(b%4==0)         
         cout<<c[3]<<endl; 
  }    
  return 0;
}

A hard puzzle

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/43762335

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!