码迷,mamicode.com
首页 > 其他好文 > 详细

(搜索) poj 1426

时间:2015-02-12 17:42:45      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

G - Find The Multiple
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

FAQ | About Virtual Judge | Forum | Discuss | Open Source P
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<queue>
using namespace std;
#define LL long long
queue<LL> q;
LL n;
LL bfs()
{
    LL x;
    while(!q.empty()) q.pop();
    q.push(1);
    while(!q.empty())
    {
        x=q.front(),q.pop();
        if(x%n==0)
            return x;
        q.push(x*10);
        q.push(x*10+1);
    }
}
int main()
{
    while(scanf("%I64d",&n)!=EOF)
    {
        if(n==0)
            break;
        printf("%I64d\n",bfs());
    }
    return 0;
}

  

(搜索) poj 1426

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4288266.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!