码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

时间:2015-02-12 22:56:33      阅读:437      评论:0      收藏:0      [点我收藏+]

标签:hdu1016   prime ring problem   dfs   acm   

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29577    Accepted Submission(s): 13188


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

技术分享
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
6 8
 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 我的第一百题和进杭电前一万名,,全贡献给了水题o(╯□╰)o
竟然格式错误两次!!
入门DFS。
下面代码:

#include <stdio.h>
#include <string.h>
#define MAX 25

bool visited[MAX] ;
int n , ans[MAX] ;
bool prime[2*MAX];

void DFS(int num)
{
	if(num == n)
	{
		if(!prime[ans[num-1]+1])
			return  ;
		for(int i = 0 ; i < n ; ++i)
		{
			printf("%d",ans[i]);
			if(i != n-1)
			{
				printf(" ");
			}
		}
		printf("\n") ;
		return ;
	}
	else
	{
		for(int i =  1 ; i <= n ; ++i)
		{
			if(!visited[i] && prime[i+ans[num-1]])
			{
				visited[i] = true ;
				ans[num] = i;
				DFS(num+1);
				visited[i] = false ;
			}
		}
	}
}

int main()
{
	for(int i = 2 ; i < 51 ; ++i)	prime[i] = true ;
	prime[0]=prime[1]=false;
	prime[2] = true ;
	for(int i = 2 ; i < 51; ++i)
	{
		for(int j = 2 ; j*i < 51 ; ++j)
		{
			prime[i*j] = false ;
		}
	}
	
	ans[0] = 1 ;
	int c=1;
	while(~scanf("%d",&n))
	{
		memset(visited,0,sizeof(visited));
		visited[1] = true ;
		printf("Case %d:\n",c++);
		DFS(1);
		printf("\n");
	}
	return 0 ;
}


hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

标签:hdu1016   prime ring problem   dfs   acm   

原文地址:http://blog.csdn.net/lionel_d/article/details/43765225

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!