码迷,mamicode.com
首页 > 其他好文 > 详细

Least Common Multiple

时间:2015-02-13 13:23:34      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34436    Accepted Submission(s): 12968


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
105 10296
 

Source
 
思路:这个题好像以前做过,但是忘了思路了,百度了一下,现在知道了。求所有数的最小公倍数,就是先两个求最小公倍数,然后所得的公倍数再与下一个数求最小公倍数。。两个数乘积除以最大公约数等于最小公倍数。
知道方法了,那么写代码就比较容易了。。我注释掉的代码是我的方法,求最大公约数,但是提交说超时了。。百度一下,可以用欧几里得定理。这样就ac了。。
节省时间,记住这个方法求最大公约数。
int gys(int a,int b)  //欧几里得求最大公约数
{
  if(b==0)
      return a;
  return gys(b,a%b);
}
#include<iostream>
using namespace std;
int gys(int a,int b)
{
  /* int i,result;               //此方法超时
   for(i=1;i<=a;i++)
   {
       if(a%i==0 && b%i==0)
          result=i;
   }
   result=a*b/result;
   return result;*/
    if(b==0) return a;          //欧几里得求最大公约数
    return gys(b,a%b);
}
int main()
{
    int T,n,i,a[1000];
    cin>>T;
    while(T--)
    {
       cin>>n;
       for(i=0;i<n;i++)
           cin>>a[i];
       for(i=0;i<n-1;i++)  //x x x x x
       {

           a[i+1]=a[i]/gys(a[i],a[i+1])*a[i+1];
       }
       cout<<a[i]<<endl;
    }
    return 0;
}

Least Common Multiple

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/43793131

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!