码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 572- Oil Deposits(简单dfs)

时间:2015-02-13 18:34:08      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Oil Deposits
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 技术分享 and 技术分享. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *‘, representing the absence of oil, or ` @‘, representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2

题意:求油井的联通块的个数


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>

using namespace std;
char mp[110][110];
int vis[110][110];
int n,m;
int jx[]={-1,-1,0,1,1,1,0,-1};
int jy[]={0,1,1,1,0,-1,-1,-1};
void dfs(int x,int y)
{
    int i;
    for(i=0;i<8;i++){
        int dx=x+jx[i];
        int dy=y+jy[i];
        if(dx>=0&&dx<n&&dy>=0&&dy<m&&mp[dx][dy]=='@'&&!vis[dx][dy]){
            vis[dx][dy]=1;
            dfs(dx,dy);
        }
    }
}

int main()
{
    int i,j;
    int cnt;
    while(~scanf("%d %d",&n,&m)){
        if(n==0&&m==0) break;
        memset(vis,0,sizeof(vis));
        for(i=0;i<n;i++)
            scanf("%s",mp[i]);
        cnt=0;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
        if(mp[i][j]=='@'&&!vis[i][j]){
            cnt++;
            dfs(i,j);
        }
        printf("%d\n",cnt);
    }
    return 0;
}


UVA 572- Oil Deposits(简单dfs)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43796175

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!