码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 657-The die is cast(dfs*2)

时间:2015-02-13 21:14:54      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:

The die is cast
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

技术分享

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence 技术分享 in S such that a = a1 and b = ak , and ai and ai+1 are connected for 技术分享.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected‘ means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy 技术分享.

The following h lines contain w characters each. The characters can be: ``.‘‘ for a background pixel, ``*‘‘ for a pixel of a die, and ``X‘‘ for a pixel of a die‘s dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output 

Throw 1
1 2 2 4


题意:给一张有很多个(至少一个)骰子的图片,判断骰子上的点数。这张图片有三种像素组成,分别是 ‘ . ‘表示背景, ‘ * ‘表示骰子, ‘ X ‘骰子中的点;两个像素共用一条边表示连接,而共用一角却不表示连接。
解题思路:两次深度搜索,先搜索筛子,再搜索筛子中有几个点。

PS:控制边界的时候少打了个等于号,wa了一天,挖槽,我的眼睛是有多瞎!saddddddd

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>

using namespace std;
char mp[110][110];
int sum[110];
int n,m,t;
int jx[]={1,0,-1,0};
int jy[]={0,-1,0,1};
void dfs1(int x,int y)
{
    int i;
    mp[x][y]='*';//找到X的时候直接将他变成*,这样就不用用vis标记,同时也不会重复计算相邻的X
    for(i=0;i<4;i++){
        int dx=x+jx[i];
        int dy=y+jy[i];
        if(dx>=0&&dx<m&&dy>=0&&dy<n&&mp[dx][dy]=='X'){
            dfs1(dx,dy);
        }
    }
}
void dfs2(int x,int y)
{
    int i;
    mp[x][y]='.';//找到X和*之间将他们变成.,少了重复计算的步骤
    for(i=0;i<4;i++){
        int dxx=x+jx[i];
        int dyy=y+jy[i];
        if(dxx>=0&&dxx<m&&dyy>=0&&dyy<n&&mp[dxx][dyy]=='X'&&mp[dxx][dyy]!='.'){
            dfs1(dxx,dyy);
            sum[t]++;
        }
        if(dxx>=0&&dxx<m&&dyy>=0&&dyy<n&&mp[dxx][dyy]=='*'&&mp[dxx][dyy]!='.')
            dfs2(dxx,dyy);
    }
}
int main()
{
    int icase=1;
    int i,j;
    while(~scanf("%d %d",&n,&m)){
        if(n==0&&m==0)  break;
        memset(sum,0,sizeof(sum));
        memset(mp,'.',sizeof(mp));
        t=0;
        for(i=0;i<m;i++)
        scanf("%s",mp[i]);
        for(i=0;i<m;i++)
        for(j=0;j<n;j++){
            if(mp[i][j]=='*'){
                dfs2(i,j);
                t++;
            }
        }
        sort(sum,sum+t);
        printf("Throw %d\n", icase++);
        for(i=0;i<t-1;i++)
            printf("%d ",sum[i]);
        printf("%d\n",sum[i]);
        printf("\n");
    }
    return 0;
}


UVA 657-The die is cast(dfs*2)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43799619

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!