码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1024---Max Sum Plus Plus

时间:2015-02-13 23:44:20      阅读:374      评论:0      收藏:0      [点我收藏+]

标签:dp

Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18190 Accepted Submission(s): 5955

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3 2 6 -1 4 -2 3 -2 3

Sample Output

6 8
Hint
Huge input, scanf and dynamic programming is recommended.

Author
JGShining(极光炫影)

Recommend
We have carefully selected several similar problems for you: 1059 1058 1227 1224 1422

Statistic | Submit | Discuss | Note

数据好像很弱 O(n^2)能过

dp[i][j][0] 表示前i个数组成j段,且不选入第i个数
dp[i][j][1]表示前i个数组成j段,且选入第i个数

dp[i][j][0] = max (dp[i - 1][j][1], dp[i - 1][j][0])
dp[i][j][1] = max (dp[i - 1][j][1], dp[i - 1][j - 1][0], dp[i - 1][j - 1][1]) + a[i];

对于j=1的情况,就是最大子段和
数据有点大,用下滚动数组

/*************************************************************************
    > File Name: dp14.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月13日 星期五 20时39分01秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 1000100;
int dp[2][N][2];
int arr[N];
int g[N];

int main ()
{
    int m, n;
    while (~scanf("%d%d", &m, &n))
    {
        memset (dp, -inf, sizeof(dp));
        for (int i = 1; i <= n; ++i)
        {
            scanf("%d", &arr[i]);
        }
        dp[0][0][0] = 0;
        g[0] = 0;
        int tmp = -inf;
        for (int i = 1; i <= n; ++i)
        {
            if (g[i - 1] + arr[i] > arr[i])
            {
                dp[i % 2][1][1] = g[i - 1] + arr[i];
                g[i] = g[i - 1] + arr[i];
            }
            else
            {
                dp[i % 2][1][1] = arr[i];
                g[i] = arr[i];
            }
            dp[i % 2][1][0] = tmp;
            tmp = max (tmp, g[i]);
            for (int j = 2; j <= m; ++j)
            {
                if (i < j)
                {
                    break;
                }
                if (i - 1 >= j)
                {
                    dp[i % 2][j][1] = max (dp[1 - (i % 2)][j - 1][0], max (dp[1 - (i % 2)][j][1], dp[1 - (i % 2)][j - 1][1])) + arr[i];
                }
                else
                {
                    dp[i % 2][j][1] = max (dp[1 - (i % 2)][j - 1][0], dp[1 - (i % 2)][j - 1][1]) + arr[i];
                }
                if (i != j)
                {
                    dp[i % 2][j][0] = max (dp[1 - (i % 2)][j][0], dp[1 - (i % 2)][j][1]);
                }
                else
                {
                    dp[i % 2][j][0] = -inf;
                }
            }
        }
        printf("%d\n", max (dp[n % 2][m][0], dp[n % 2][m][1]));
    }
    return 0;
}

hdu1024---Max Sum Plus Plus

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/43803465

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!