在数学书我们曾经学过求多项式系数的问题吧,但是编程上怎么办呢?
先给一道例题看看吧
Easy Task
Calculating the derivation of a polynomial is an easy task. Given a function f(x) , we use (f(x))’ to denote its derivation. We use x^n to denote xn. To calculate the derivation of a polynomial, you should know 3 rules:
(1) (C)’=0 where C is a constant.
(2) (Cx^n)’=C*n*x^(n-1) where n>=1 and C is a constant.
(3) (f1(x)+f2(x))’=(f1(x))’+(f2(x))’.
It is easy to prove that the derivation a polynomial is also a polynomial.
Here comes the problem, given a polynomial f(x) with non-negative coefficients, can you write a program to calculate the derivation of it?
Input
Standard input will contain multiple test cases. The first line of the input is a single integerT (1 <= T <= 1000) which is the number of test cases. And it will be followed byT consecutive test cases.
There are exactly 2 lines in each test case. The first line of each test case is a single line containing an integerN (0 <= N <= 100). The second line contains N + 1 non-negative integers,CN, CN-1, …, C1, C0, ( 0 <= Ci <= 1000), which are the coefficients of f(x).Ci is the coefficient of the term with degree i in f(x). (CN!=0)
Output
For each test case calculate the result polynomial g(x) also in a single line.
(1) If g(x) = 0 just output integer 0.otherwise
(2) suppose g(x)= Cmx^m+Cm-1x^(m-1)+…+C0 (Cm!=0),then output the integersCm,Cm-1,…C0.
(3) There is a single space between two integers but no spaces after the last integer.
Sample Input
3
0
10
2
3 2 1
3
10 0 1 2
Sample Output
0
6 2
30 0 1
这道例题的意思是先给你一个T,然后是有T组测试样例,然后给你一个n,表示有n+1个数,让你求多项式的系数,注意,如果n=0,输出的是0.
下面给代码喽
#include<stdio.h>
int main()
{
int t, n, i, j, a[1000], b[1000];
while(~scanf("%d", &t))
{
for(i=0;i<t;i++)
{
scanf("%d", &n);
for(j=0;j<=n;j++)
{
scanf("%d", &a[j]);
b[j]=a[j]*(n-j);
}
if(n==0)
{
printf("0");
}
else
{
for(j=0;j<n;j++)
{
printf("%d", b[j]);
if(j!=n-1)
{
printf(" ");
}
}
}
printf("\n");
}
}
return 0;
}
原文地址:http://blog.csdn.net/unusualnow/article/details/43817743