码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1114 Piggy-Bank 完全背包

时间:2015-02-15 21:50:48      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114

题意分析:给出存钱罐存钱前后的重量,以及钱的种类及其价值和种类, 要求装满存钱罐最小的价值。  完全背包

/*Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13578    Accepted Submission(s): 6863


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
 

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
 

Source
Central Europe 1999
 
*/
//完全背包变形
#include <cstdio>
#include <cstring>
#define N 1000 + 10
const int maxn = 10000 + 10;
int dp[maxn], n, V;
int p[N], w[N];
int Min(int a, int b)
{
    return a > b ? b : a;
}

void Pack(int p, int w)
{
    for(int i = w; i <= V; i++)
        dp[i] = Min(dp[i], dp[i-w]+p);
}

int main()
{
    int t, low, hign;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &low, &hign);
        V = hign - low;
        scanf("%d", &n);
        for(int i = 1; i <= V; i++) dp[i] = 5000000;
        dp[0] = 0;
        for(int i = 0; i < n; i++)
            scanf("%d%d", &p[i], &w[i]);
        for(int i = 0; i < n; i++)
            Pack(p[i], w[i]);
        if(dp[V] == 5000000) printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n", dp[V]);
    }
    return 0;
}

 

hdu 1114 Piggy-Bank 完全背包

标签:

原文地址:http://www.cnblogs.com/ACFLOOD/p/4293496.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!