码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3555 数位dp

时间:2015-02-15 21:55:53      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=3555

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
3 1 50 500
 

Sample Output
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

/**
hdu 3555 数位dp
题目大意: 给定一个闭区间,求区间内有多少数中含“49”。
解题思路:dp[i][j]表示i位数以j为最高位位中的所有不符合数的个数。做一下预处理,求出10^6内的所有dp值,然后统计给定区间内的即可
           注意:eg:原数1347,转换到数组我表示为7431
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long LL;

LL l;
LL dp[25][12];

void init()
{
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1;i<21;i++)
    {
        for(int j=0;j<=9;j++)///最后一位的取值
        {
            for(int k=0;k<=9;k++)///倒数第二位的取值
            {
                if(!(j==4&&k==9))
                    dp[i][j]+=dp[i-1][k];
            }
        }
    }
/**
    for(int i=1;i<21;i++)
    {
        for(int j=0;j<=9;j++)
        {
            printf("%I64d ",dp[i][j]);
        }
        printf("\n");
    }*/
}
LL solve(LL n)
{
    int a[25],len=0;
    while(n>0)
    {
        a[++len]=n%10;
        n/=10;
    }
    a[len+1]=0;
    LL ans=0;
    for(int i=len;i>0;i--)
    {
        for(int j=0;j<a[i];j++)
        {
            if(!(a[i+1]==4&&j==9))
            {
                ans+=dp[i][j];
            }
        }
        if(a[i]==9&&a[i+1]==4)break;
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    init();
    while(T--)
    {
        scanf("%I64d",&l);
        printf("%I64d\n",l+1-solve(l+1));
    }
    return 0;
}


hdu3555 数位dp

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/43837505

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!