码迷,mamicode.com
首页 > 其他好文 > 详细

杭电ACM 五 另一种Fibonacci

时间:2015-02-16 14:21:25      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   大一练习   

问题及代码:

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no
/*
*Copyright (c)2014,烟台大学计算机与控制工程学院
*All rights reserved.
*文件名称:team.cpp
*作    者:冷基栋
*完成日期:2015年2月16日
*版 本 号:v1.0
*/
#include <iostream>
using namespace std;
int main()
{
    int n;
    while (cin>>n)
    {
        if ((n-2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
return 0;
}

运行结果:

技术分享

知识点总结:

合理余数进行整除运算 循环节
学习心得:

好好学习 天天向上






杭电ACM 五 另一种Fibonacci

标签:acm   c++   大一练习   

原文地址:http://blog.csdn.net/ljd939952281/article/details/43851311

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!