标签:acm c++ 大一练习
问题及代码
Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you
tell Ignatius the area of the land?
Note: The point P1 in the picture is the vertex of the parabola.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
Sample Output
/*
*Copyright (c)2014,烟台大学计算机与控制工程学院
*All rights reserved.
*文件名称:team.cpp
*作 者:冷基栋
*完成日期:2015年2月16日
*版 本 号:v1.0
*/
#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
int n;
double x1,x2,x3,y1,y2,y3;
cin>>n;
while (n--)
{
double k,s;
cin>>x1>>y1>>x2>>y2>>x3>>y3;
k = (y2-y1)/((x2-x1)*(x2-x1));
s = (k*(x3-x1)*(x3-x1)*(x3-x1))/3 - k*(x2-x1)*(x2-x1)*(x2-x1)/3 + y1*(x3-x2);
s -= (y3+y2)*(x3-x2)/2;
cout <<setiosflags(ios::fixed)<<setprecision(2)<< s << endl;
}
return 0;
}
运行结果:
知识点总结:
微积分and方程
学习心得:
好好学习 天天向上
杭电ACM 三 在坐标系中的微积分
标签:acm c++ 大一练习
原文地址:http://blog.csdn.net/ljd939952281/article/details/43851901